请选择 进入手机版 | 继续访问电脑版

kangle软件 是一款高性能跨平台web服务器

 找回密码
 注册
kangle web软件将启用新域名 kangleweb.com 作为kangle软件官方网站网址
kangle web服务器最新版下载
kangle访问控制模块介绍 -  kangle设置优化原则
kangle中文帮助手册 -产品购买
easypanel 虚拟主机控制面板最新版
easypanel虚拟主机控制面板功能列表
easypanel中文帮助手册 - 讨论
   kangle虚拟主机管理下载 - 安装 - 帮助手册
    
   销售: 在线客服QQ   技术支持: 在线客服QQ
    kangle web (介绍, 功能特性, 运行环境, 安装说明, 常见问题, 使用教程)     easypanel主机控制面板 (介绍, 功能特性, 安装说明, 常见问题, 使用教程)
    vhms系统 (介绍, 安装说明, 常见问题, 使用教程)     [kangle软件交流QQ群:104434948]
查看: 9400|回复: 4

UPUPW Kangle版全能服务器绿色平台UP-K1.8 支持最新PHP7全系列

[复制链接]
发表于 2015-12-11 17:20:13 | 显示全部楼层 |阅读模式
本帖最后由 柒铖鸿 于 2015-12-11 17:22 编辑


百度下载地址:http://pan.baidu.com/s/1skwgNEl

小站测试:  bbs4.cn

UPUPW Kangle版全能服务器绿色平台K1.8采用Windows平台下支持IOCP工作模型的Kangle3.5.4为核心制作而成。

支持PHP全系列版本自由切换、同时运行;支持站点绑定PHP任意版本或ASP/.NET2/4且不依赖IIS,本次更新增加新一代的PHP7.0版本。

K1.8更新:

01、更新Kangle到Kangle3.5.4
02、更新MariaDB到MariaDB10.1.9
03、更新PHP到PHP5.4.45、PHP5.5.30、PHP5.6.16
04、更新phpMyAdmin到phpMyAdmin4.4.15
05、更新ionCube Loader到ionCube Loader5.0.17
06、更新Xdebug到Xdebug2.3.3
07、更新upupw php探针到15.12.5安全版。
08、维护PHP5.2.17-upupw,修复了dos、Hash及openssl漏洞。
09、维护PHP5.3.29-upupw,修复了dos、Hash及openssl漏洞。
10、增加PHP7.0.0正式版,支持UPUPW面板建立网站时绑定。
11、增加PHP7的xdebug组件。
12、增加PHP5.5和PHP5.6的Zend GuardLoader解密组件。
13、增加所需VC库到环境包,除个别原因外无需再单独安装VC库。
14、增加获取用户真实IP配置,避免使用CDN后读取不到用户的真实IP日志报告中全是单IP的情况。
15、增加php.ini文件并同步php5x.ini的配置,用于某些程序调用php.exe时不指定配置文件无法加载组件的问题。
16、更改UPUPW PHP探针数据库连接检测模式为mysqli。
17、美化UPUPW控制面板功能选项和整体布局,用[]突出对应功能命令
18、修复UPUPW PHP探针注入漏洞以及服务器时间不准确的问题。
19、修复自定义数据库data目录位置后实际成功启动但UPUPW面板一直提示启动失败的问题。
20、修改session.auto_start参数为1,自动调用php_session_start来开启会话。
21、避免多版本PHP同时开启OPcache导致冲突出现504错误,面板调整为只允许开启一个PHP版本的OPcache。
22、避免Zend GuardLoader开启后OPcache和xCache同时开启会导致冲突,面板调整为关闭对应PHP版本的xCache。
23、默认关闭.NET2/.NET4组件,改为新增.NET站点时自动开启,防止未装对应库导致Kangle异常退出。
24、默认关闭K进程守护程序,改为按需在UPUPW面板安全防护里开启,S1不装.NET库即可开启全部服务。
25、upupw面板使用静态库编译,不再依赖外部VC库,提高面板的便捷性。
Kangle3.5.4新特性:

支持chunked方式post数据
支持Etag方式缓存
支持websocket
新增path_sign,防盗链签名模块
新增try_file匹配模块
新增http10的标记模块
新增cname绑定模式
UPUPW特色功能:

支持PHP全系列版本自由切换、同时运行
支持本地和服务器上使用或者U盘运行,支持本地打包移植到服务器
支持进程守护功能,在网站无法访问时自动执行启动命令
支持全面的访问控制(request和response),包括IP地址端口,url,连接数限制,网速限制,http头,时间控制,认证,服务器负载,重定向,url重写等
集成PHP5.2.17 PHP5.3.29 PHP5.4.45 PHP5.5.30 PHP5.6.16 PHP7.0.0全系列目前官方最新版本
建立虚拟主机时可选择绑定ASP和ASP.NET或PHP等解析语言,满足不同网站程序的需求
Kangle伪静态兼容apache的.htaccess功能
虚拟主机可独立进程、独立身份运行,网站之间安全隔离,一个网站出问题不会影响其它网站
控制面板+图形化Web管理界面实现服务器与本地的双重管理模式
全面、强大、灵活的访问控制和回应控制功能,可自定义多重功能
自动检测重起有问题的子进程,防止服务假死
UPUPW面板安全防护支持防注入攻击、防跨站目录限制、禁止外部管理kangle web页面、隐藏PHP头部信息、禁用未绑定域名访问、禁用PHP不安全函数执行等功能
upupw面板强大的MySQL/MariaDB管理面板支持瞬间导入、导出数G数据的功能
UPUPW默认已开启Rewrite伪静态支持、Gzip页面压缩传输支持、pathinfo路径支持、防止木马上传等功能
全面优化的kangle/PHP/ASP/ASP.NET/MYSQL/MariaDB等配置文件,打开UPUPW面板s1一键开启即可运行网站
UPUPW主体部分:

Kangle/3.5.4   在Win下支持IOCP工作模型的Web服务器软件
PHP5.2.17/PHP5.3.29/PHP5.4.45/PHP5.5.30/PHP5.6.16/PHP7.0.0全系列
MariaDB/10.1.9   采用Maria存储引擎的MySQL分支版本,有着更强的性能和兼容性
phpMyAdmin/4.4.15   开源、基于WEB而小巧的MySQL管理程序
SendMail   目前使用最为广泛的一种E-mail服务器邮件传输代理程序
FileZilla server   高安全、高性能FTP服务器端程序可以单独作为FTP服务器端使用
UPUPW重要组件:

Zend Optimizer/3.3.3   解密加代码优化,提高PHP应用程序的执行速度,显著降低服务器的CPU负载
Zend GuardLoader/5.5.0/6.0/7.0   解密加代码优化,提高PHP应用程序的执行速度,显著降低服务器的CPU负载
ionCube Loader/5.0.17   解密加代码优化,执行ionCube加密过的PHP代码
XCache/3.2   高速的PHP脚本缓存组件
Zend OPcache/7.06   PHP代码高效缓存加速器,优化程序,编码器和动态内容缓存
memcache/3.0.8   高性能的分布式的内存对象缓存系统
oAuth/1.2.3   OAUTH协议为用户资源的授权提供了一个安全的、开放而又简易的标准
Xdebug   PHP程序调试器,跟踪、调试和分析PHP程序的运行状况
UPUPW PHP/ASP探针   支持服务器信息检测,PHP/ASP组件检测,PHP已编译模块检测,数据库连接测试等
UPUPW控制面板:

UPUPW一键式Kangle+PHP+ASP/NET+memcached+数据库服务开启与关闭控制面板
UPUPW内置小型的数据库管理面板,添加,删除,修改,导入,导出快捷方便
支持Kangle服务的单独开启、关闭与重启
支持数据库服务的单独开启与关闭
支持memcached服务的单独开启与关闭
支持虚拟主机添加、修改、删除等设置
支持Kangle和数据库端口更改
支持现有端口检测,排查异常端口占用情况
支持强制或常规重设数据库密码
支持数据库新建、删除、导入、导出
支持网站数据库特性由旧版本升级为新版本
支持Kangle功能设置
支持本机Hosts文件重定向本地域名解析
支持高级服务清理工具
支持定制服务扩展窗口
支持UPUPW安全防护功能
支持UPUPW进程守护功能
支持PHP功能组件开启关闭
支持主机性能适配功能
支持生产开发环境选项
支持FTP服务器端管理模块
支持集成包配置文件的备份与还原
UPUPW注意事项:

1、K1.8版Kangle不支持XP系统,但适应2003系统,PHP5.5往上不再支持2003系统
2、默认已集成需要的VC库,如出现不能运行的情况请查看运行库说明.txt
3、PHP多版本同时运行虽方便但建议没有特殊版本要求的站点绑定同一个PHP版本
4、Opcache缓存开启后如经常出现504错误说明和网站程序不兼容建议关闭Opcache
5、ASP和ASP.NET网站建议选择upupw kangle 32位版本,组件齐全兼容性好
6、504错误是后端PHP问题一般为VC库冲突、PHP版本不支持、PHP组件冲突、超时
7、记住修改数据库密码、kangle后台web密码、服务器部署后删除所有.txt说明
8、PHPX目录下所有php.ini文件仅用于PHP.EXE进程,PHP-CGI调用的是PHP5X.ini
UPUPW系统需求:

操作系统---Windows Server 2003/2008/2012/2016 ; Vista/Win7/Win8.1/Win10 ; 32/64位通用版
处 理 器---2.0GHz及以上
内     存---2GB及以上
硬     盘---存储需要500MB空间,运行至少需要1GB剩余空间
回复

使用道具 举报

发表于 2017-4-22 00:54:32 | 显示全部楼层
可惜不能让easypanel也能自由切换 PHP5.2.17/PHP5.3.29/PHP5.4.45/PHP5.5.30/PHP5.6.16/PHP7.0.0
回复 支持 1 反对 0

使用道具 举报

发表于 2016-5-17 22:53:56 | 显示全部楼层
抢沙发,楼下做板凳
回复 支持 反对

使用道具 举报

发表于 2017-4-7 18:33:17 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
回复 支持 反对

使用道具 举报

发表于 2017-4-8 22:08:03 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|Archiver|Bangteng Inc. ( 赣ICP备13005708号-5

GMT+8, 2017-12-12 12:31 , Processed in 0.055809 second(s), 23 queries , Gzip On.

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表